Суббота, 18.11.2017, 00:02
Приветствую Вас Заблудший(Гость) | RSS
Главная | Каталог статей | Регистрация | Вход
Меню сайта
Категории каталога
с++ [1]
Java [6]
та которая Java машина
Работа в 1c [1]
Форма входа
Поиск
Друзья сайта

Статистика
Pir
Главная » Статьи » Программирование » Работа в 1c

Алгоритм перевода фамилии в дательный падеж
Ниже представлена функция перевода фамилии в дательный падеж
Code

//Фамилия в дательном падеже
Функция ДательныйПадеж(прм_Фио)
  стр=СокрЛП(прм_Фио);
  п=Найти(стр," ");
  Если п=0 Тогда
  стр1=СокрЛП(стр);//фамилия
  стр2="";//окончание
  Иначе
  стр1=СокрЛП(лев(стр,п));
  стр2=СокрЛП(сред(стр,п));
  КонецЕсли;
  стр1=стр1+" ";
   
  Если Найти(стр1,"о ")>0 Тогда
  //не изменяем
  ИначеЕсли Найти(стр1,"и ")>0 Тогда
  //не изменяем
  ИначеЕсли Найти(стр1,"а ")>0 Тогда  
  стр1=СтрЗаменить(стр1,"а ","ой ");
  ИначеЕсли Найти(стр1,"ая ")>0 Тогда  
  стр1=СтрЗаменить(стр1,"ая ","ой ");
  ИначеЕсли Найти(стр1,"ий ")>0 Тогда  
  стр1=СтрЗаменить(стр1,"ий ","ому ");
  ИначеЕсли Найти(стр1,"ь ")>0 Тогда  
  стр1=СтрЗаменить(стр1,"ь ","ю ");
  Иначе
  стр1=СтрЗаменить(стр1," ","у ");
  КонецЕсли;
  Возврат стр1+ стр2;
КонецФункции

взято со
страницы

Категория: Работа в 1c | Добавил: Xapac (19.06.2009)
Просмотров: 3198 | Рейтинг: 3.0/2 |
Всего комментариев: 0

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Copyright MyCorp © 2017